Cake Central › Cake Forums › Cake Talk › Recipes › What am I doing wrong with this icing recipe?????
New Posts  All Forums:Forum Nav:

What am I doing wrong with this icing recipe?????

post #1 of 10
Thread Starter 
Ok, I've used this icing recipe about 5 times with no issues but for some reason it is no longer working. I use it for a cookies and cream cake but will reserve some frosting before adding the cookies. It's always been firm enough to pipe. The last 3 times though, it is soooo runny, it would be impossible to pipe. Thinking that maybe I had used name brand ingredients previously, I went to the store, bought more supplies and tried again.....same runny results. Tried adding more PS, that made it taste like PS and too sweet but still runny. Any ideas what is going on? Here is the recipe

1 (8oz) package cream cheese, softened
1 (16oz) box powdered sugar
1 (8oz) container Cool Whip, room temperature
15 oreos, crushed
1/4 tsp vanilla extract

Cream the cheese and sugar in mixer. Add vanilla, mix well, and stir in cool whip. Mix well. Fold in crushed oreos until well blended.
post #2 of 10
If that happens to me, it's because it's humid. It may be that that's causing your icing to run. Ever tried using a fan around your work area? It may help if that's the case. Just keep it at a distance blowing off a wall. I hope that helps you. icon_smile.gif
post #3 of 10
I'm guessing it's the Cool Whip. It isn't made to be "room temperature" and has probably become destabilized. It folds in just fine as long as it's thawed, so try keeping it in the refrigerator until you're ready to use it.
post #4 of 10
Thread Starter 
Thanks for the suggestions. I'm going to try both ideas. I honestly can't remember if I ever let the cool whip get to room temp. before but I did the last 2 times for sure....hmmmmm....maybe that's the problem.
post #5 of 10
From my experience using it, If you work Cook Whip too much or let it get too warm it will flatten and get runny.
post #6 of 10
Thread Starter 
Thanks for your input! I'm determined to figure this out since I love the way this tastes!
post #7 of 10
Are you perhaps using less Cool Whip than needed? Reason I'm asking is that so many manufacturers are cutting back on amount of product and keeping it in the same size container that it can screw up recipes big time. You think you're adding the correct amount but it actually ends up being a couple of ounces shy. I wouldn't think that less cool whip would have that much affect, but you never know. Also, I've been hearing lately that trans fat...or the lack of...is creating issues. Don't really know if Cool Whip has ever had that or not.
Just some random thoughts!

If I am ever on life support, unplug me...

Then plug me back in.  See if that works!

Reply

If I am ever on life support, unplug me...

Then plug me back in.  See if that works!

Reply
post #8 of 10
Thread Starter 
I will check into that. I know I didn't look at the amount when I bought the Cool Whip, just grabbed the small one.
post #9 of 10
I have a substitution suggestion. Try exchanging the Cool Whip with marshmallow cream.
post #10 of 10
Thread Starter 
That sounds good. I will try that too. Thanks!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Recipes
Cake Central › Cake Forums › Cake Talk › Recipes › What am I doing wrong with this icing recipe?????